Latest Discussions : HVAC

sdkomoroff

03:20AM | 10/05/03
Member Since: 10/04/03
3 lifetime posts
we have a 1987 home with electrical baseboard heaters. One is no loner working, there are two clicks when I turn it on but no heat. is ther a fuse that needs replacing or the thermastst? or do we replace the whole thing? Thanks
Sandy

daveg

04:44AM | 10/05/03
Member Since: 03/01/03
22 lifetime posts
Did you check for power at the thermostat? Could just be a tripped circuit breaker or a bad thermostat.

sdkomoroff

02:13PM | 10/05/03
Member Since: 10/04/03
3 lifetime posts
there is power to the heater. How do you tell if the thermostat is bad?
Sandy

dgalenski

07:54AM | 10/06/03
Member Since: 01/02/03
31 lifetime posts
If there is no power at the thermostat, the problem probably is a circuit breaker. If there is power at the thermostat, and you turn it until it clicks, power should pass through the thermostat. My EBB thermostats run off of line voltage. They switch the "Hot" to the baseboard.

sdkomoroff

02:55PM | 10/06/03
Member Since: 10/04/03
3 lifetime posts
This is the last time I listen to my husband. he told me there was power to the heater sooooI didn't look. after I examined the circuit breaker ---that was the problem. He redeemed imself by changing a light bulb for me so I guess he is good for that but its the last time i listen to his diagnosis. Thanks for all your advice Sandy


Post a reply as Anonymous

Photo must be in JPG, GIF or PNG format and less than 5MB.

Reply choose button

Anonymous

Post new button or Login button
Register