Latest Discussions : Electrical & Lighting

superdow

03:57AM | 12/31/02
Member Since: 10/10/02
4 lifetime posts
I was given a fairly old ***** coldspot freezer (18.5 upright frostless model no. 2354). I set it up at home and it doesn't run. Interestingly, I notice that the
interior light does not work when the door is open. (I removed and screwed it into a lamp socket so I know that the bulb is in operating order). I also checked
to make sure that there is power comining into the outlet that I have plugged the freezer into.

Could there be a simple solution? perhaps a blown fuse somewhere> The thing was last plugged in about two years ago but was working at the time. TIA -Ray

DanO

08:09AM | 12/31/02
Member Since: 11/11/02
2267 lifetime posts
** perhaps a blown fuse somewhere **

There is no fuse in the freezer itself. If you have power at the outlet, the only fuse for it (in your house fuse panel) must be Ok.

** The thing was last plugged in about two years ago but was working at the time. **

Can you hear the compressor running?

If not, it could be just a wire off somewhere, you'd have to trace the wiring to see if you can find it. (The wiring on freezers is pretty simple.)

If the compressor is running but the unit is not cooling, the freezer is likely out of refrigerant and now likely not worth repairing.

From the Useful Freezer Tips from the 'Home Service' section of my site linked below:

quote:
Do not leave your freezer unplugged for a lengthy time. The condenser coils welded inside the cabinet are made of steel, while running they are kept hot evaporating moisture. When not operational, they are exposed to the moisture and rust out. The refrigerant gas then leaks out and major repairs are required.

Dan O.
www.Appliance411.com
The Appliance Information Site

=Ð~~~~~~

[This message has been edited by DanO (edited December 31, 2002).]

superdow

08:51AM | 12/31/02
Member Since: 10/10/02
4 lifetime posts
Thanks for the tips. There is no sound
from the compressor. No sounds whatsoever. This plus the fact that the interior light doesn't work leads me to believe, as you suggest, that the problem is electrical. I'll take the back cover off and see if I can find a loose wire and also check the cord thorougly....


Post a reply as Anonymous

Photo must be in JPG, GIF or PNG format and less than 5MB.

Reply choose button

Anonymous

Post new button or Login button
Register