Latest Discussions : Tools & Workshop

cabrego

09:17PM | 01/23/06
Member Since: 01/23/06
2 lifetime posts
I have a 6hp, 33gal, 240v twin oil less craftsman. I know these have a bad reputation...I have this compressor for close to 5years and have just started to have some problems with it.

It would not charge up past 60psi. It would not shut off at 60, and what loose its tank psi over nite. I also must admit I am guilty of running at well above max psi for a couple of weeks prior.

I opened her up and found broken fins on one of my valve plates. "BINGO" right? WRONG! I replaced the valve plate piston-ring and sleeve oring. (it was shot) and sleeve. Put her back together and same problem, it did pump up faster though.

Well to make a longer story just long, I opened up the manifold. I could not find a check valve, I did find a flapper valve over a oring type bushing..is that combo actually the check? I am suprised to not see a check valve. Any ideas?

Well sears sells a new manifold(different part#) with a check valve? Curious to see what it looks like maybe an improved part.

Well I did not replace all the seals and orings when I put it together, was that a bad move??!? I thought they would be ok, but maybe 5 years is to much ?)

I am use to the lound compressor and think this may be my best move. LMK guys thanks!

cabrego

07:59PM | 01/24/06
Member Since: 01/23/06
2 lifetime posts
Wheres bob when you need him?@?


Post a reply as Anonymous

Photo must be in JPG, GIF or PNG format and less than 5MB.

Reply choose button

Anonymous

Post new button or Login button
Register