Latest Discussions : Electrical & Lighting

SMITHDOI

07:34PM | 04/30/10
Member Since: 04/29/10
3 lifetime posts
Burners working fine. Oven and broiler stopped working. Installed new ignitor Tues 4/26/10. Oven worked fine, used to make dinner, cookies, etc. Can't remember if we used broiler...think we did. Now, Friday 4/30, Oven and broiler not working AGAIN! Burners are still fine, as always. What could cause this? It seems crazy!

DanO

04:56PM | 05/01/10
Member Since: 11/11/02
2267 lifetime posts
Your oven used a hot surface (glow ignitor) ignition system. A first step in diagnosing problems with such a system is observing what the ignitor is doing when the oven should be heating, as explained at the following link:

- Understanding Gas Oven Ignition Systems

LINK > www.appliance411.com/links/jump.cgi?ID=823

JFYI

Dan O.

www.Appliance411.com/parts/?ref411=GE+Range

The Appliance Information Site

=D~~~~~~

SMITHDOI

05:08PM | 05/01/10
Member Since: 04/29/10
3 lifetime posts
Ignitor is doing nothing. No glowing, no clicking, no gas smell, just nothing.

SMITHDOI

05:11PM | 05/01/10
Member Since: 04/29/10
3 lifetime posts
Thanks for link. It is very helpful. When installing, one of the wires was short. I'm concerned that maybe it's not making a connection behind stove, even though it WAS working. Don't know what wiring looks like behind stove, so don't know if it's even worth taking apart to see it. I mean, that issue might be RARE so I'd be better off checking switch, maybe?


Post a reply as Anonymous

Photo must be in JPG, GIF or PNG format and less than 5MB.

Reply choose button

Anonymous

Post new button or Login button
Register